Commons:Bots/Requests/John Bot II 2

From Wikimedia Commons, the free media repository
Jump to: navigation, search

John Bot II[edit]

Operator: CWii(Talk|Contribs)

Automatic or Manually Assisted: Automatic

Programming Language(s): Python

Edit period(s) (e.g. Continuous, daily, one time run): Daily

Bot flag requested: (Y/N): Bot has flag.

Functions: The images will be first approved by humans using my script. Then they will be moved over to the commons and marked for CSD:I8 here.

The bot will also do tasks such as removing move to commons templates from images that users have tagged, and marking Images that were already moved.

The code will be posted after some finishing touches.

A parallel request is being made at en:Wikipedia:Bots/Requests for approval/John Bot II 3, the code is at en:User:John Bot II/Source Assembla

Discussion[edit]

Could you please make a test run? What about moved images categorization? --EugeneZelenko (talk) 14:12, 13 October 2008 (UTC)
The images will have the chance to be manually categorized with my tool on en wiki, then will be put through CommonsHelper. If there are still no categories then it will be marked with {{unc}}. I can't do a test run until BAG gives me a trial. CWii(Talk|Contribs) 19:32, 13 October 2008 (UTC)
Approved for trial on enwiki. Mr.Z-man (talk) 02:12, 20 October 2008 (UTC)
TRIAL IS DONE CWii(Talk|Contribs) 19:46, 22 October 2008 (UTC)
I think will be good idea to refer to original image page in Source field not just Wikipedia. --EugeneZelenko (talk) 14:15, 24 October 2008 (UTC)
Investigating... CWii(Talk|Contribs) 19:36, 24 October 2008 (UTC)
Image:Asia_1300bc.jpg#Original_upload_log The link is in there, I put the images through CommonsHelper for formatting and categories, but can always change/move the link. I'm fixing this. CWii(Talk|Contribs) 19:39, 24 October 2008 (UTC)
Fixed. Approved on Wikipedia. CWii(Talk|Contribs) 18:24, 25 October 2008 (UTC)
Could you please make a new test run? --EugeneZelenko (talk) 15:42, 26 October 2008 (UTC)

← Sure, I'll move 1 image. CWii(Talk|Contribs) 20:33, 26 October 2008 (UTC)

1 image moved, but it's broken somehow on wpen CWii(Talk|Contribs) 20:41, 26 October 2008 (UTC)
✓ Done and fixed. CWii(Talk|Contribs) 21:55, 26 October 2008 (UTC)
Looks OK for me. --EugeneZelenko (talk) 14:16, 27 October 2008 (UTC)
So is there anything else to do or can I start this for real? CWii(Talk|Contribs) 12:25, 31 October 2008 (UTC)
Hi Cwii, just figured something out. The lists for the filters have to be initialized (forgot about that). You have to run imagerecat.initLists() before you can run applyAllFilters. Now the blacklist and the country filter dont work. Multichill (talk) 20:15, 3 November 2008 (UTC)
Fixed CWii(Talk|Contribs) 21:42, 3 November 2008 (UTC)

Approved, already flagged. Giggy (talk) 01:45, 28 November 2008 (UTC)