File talk:Wikiversity-logo.svg

From Wikimedia Commons, the free media repository
Jump to navigation Jump to search

"version"-attribute of xml-statement[edit]

First line in that SVG-file should be changed for correct interpretation by some browsers:

instead of
<?xml version="1" encoding="iso-8859-1"?>
should be written
<?xml version="1.0" encoding="iso-8859-1"?>

i.e. the "version"-attribute should be "1.0" instead of only "1" --Exxu (talk) 07:25, 9 July 2008 (UTC)

Please move from Category:Wikiversity to Category:Wikiversity logos. Urhixidur (talk) 15:30, 8 August 2008 (UTC)

You're wriong. For standard SVG files, there's NO need of any XML declaration directive. If you look closer, you'll see that this SVG file DOES NOT include any XML declaration, as expected. So there's NO such error (if you've got this error, it can only come from your renderer that incorrectly adds it when you ask to it to present the source).
Check by yourself: download the file (by right clicking the image and click "save as..." from the information page, instead of folowing its link to present it in your renderer).
Note that the DTD's URL has changed since its initial specifications. This now generates a benign warning (because it no logner matches the URL used in the W3C validator, according to its system identifier), but does not invalidate the file. May be this should be changed as well (but almost all conforming SVG renderers do not use this URL, but just the system identifier, only to assert which version of the SVG specification to use in their own internal schema, instead of downloading an external DTD, as they work in standalone mode). Of course we can change this URL, but this will not impact the way the file is rendered, or the fact that it is already validated. 79.94.111.109 00:54, 28 July 2009 (UTC)

On Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090910 Ubuntu/9.04 (jaunty) Shiretoko/3.5.3 I get this error:

XML Parsing Error: XML declaration not well-formed
Location: http://upload.wikimedia.org/wikipedia/commons/9/91/Wikiversity-logo.svg
Line Number 1, Column 16:<?xml version="1" encoding="UTF-8" standalone="no"?>
---------------^

--Nemo 07:49, 10 October 2009 (UTC)


I got the same error message with Opera - and the browsers are right:
1. There is an XML declaration at the top of the SVG file.
2. The XML recommendation notes, that there should be one in any XML file at the top.
3. The version attribute in the file has the value '1'.
4. According to the XML recommendation the version attribute value has to start with '1.' followed by one or more digits between 0 and 9. Currently there are the versions '1.0' and '1.1' possible.
5. On the other hand on can skip 'encoding="UTF-8" standalone="no"' instead, just because UTF-8 is the default and standalone is not important.
Doktorchen (talk) 18:34, 7 May 2010 (UTC)


Yeah this was an issue and I'm a bit shocked no one fixed it earlier. If downloaded it failed in almost all browsers and most svg viewers/editors. I fixed and reuploaded. Jalexander (talk) 01:32, 10 March 2012 (UTC)

Wrong DTD[edit]

This SVG file contain a wrong DTD, it is to old : http://www.w3.org/2000/svg

We must use a correct DTD : http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd.

Thanks to update the file.

Note : we've identified this bug in developpement of Wikifundi V2 , because we import this file with Pywikibot in a other Wikimedia for offline access . We got this error : APIError: verification-error: Cannot upload SVG files that contain a non-standard DTD declaration. [help:See http://localhost/w/api.php for API usage. Subscribe to the mediawiki-api-announce mailing list at <https://lists.wikimedia.org/mailman/listinfo/mediawiki-api-announce> for notice of API deprecations and breaking changes.; details:['upload-scripted-dtd']]

— Preceding unsigned comment added by Flockies (talk • contribs) 10:09, 12 July 2018 (UTC)