User talk:Rotatebot/Archive/2012

From Wikimedia Commons, the free media repository
Jump to: navigation, search
Archive This is an archive of past discussions. Do not edit the contents of this page. If you wish to start a new discussion or revive an old one, please do so on the current talk page.

was this a network error?

File:Dulac_Church_%28Louisiana%29.jpg&action=history. I know, that yesterday there were problems at the WMF servers. Cheers --Saibo (Δ) 00:58, 20 January 2012 (UTC)

looks like a server error:
[...]
Seite geladen, Anmeldung prüfen.
Anmeldung erfolgreich!
Content (76932 Zeichen) vorbereitet, verbinde zum Speichern!

Header gesendet.
BEARBEITUNG FEHLGESCHLAGEN!.
[...]

Schlechtes Log ;)--Luxo 16:24, 20 January 2012 (UTC)

Danke, dann ignorieren wir mal und hoffen auf besseres Netzwerk/weniger Serverfehler! Wenn ich den Programmierer erwische, der das grottige Log gebastelt hat.... ;-) Viele Grüße --Saibo (Δ) 22:02, 22 January 2012 (UTC)
This section was archived on a request by: Saibo (Δ) 22:02, 22 January 2012 (UTC)

Has Rotatebot stopped?

For example, File:SwiftHeadwaters.jpg got a {{rotate}} template about 10 hours ago but hasn't been rotated yet. --Stefan4 (talk) 19:12, 17 February 2012 (UTC)

Looking at...--Saibo (Δ) 19:56, 17 February 2012 (UTC)
Dead for some reason - could not restart it. I have written a mail to Luxo. Cheers --Saibo (Δ) 20:11, 17 February 2012 (UTC)
Reason: http://status.toolserver.org/ "Internal Server Error" Root cause: Today is planned toolserver maintenance (IRC: "[2012-02-17 10:28:26] <DaB|DC> We starting today's maintaince now"). So: just wait. --Saibo (Δ) 20:22, 17 February 2012 (UTC)
I see. I'll fill up the category in the meantime. --Stefan4 (talk) 20:23, 17 February 2012 (UTC)
exactly, down because of maintenance since noon... Greetings,--Luxo 21:30, 17 February 2012 (UTC)
Apparently it is some bigger problem... I have heared from two sources that Nightshade is not up (and will not be soon) - afaik rotatebot runs there... :-( Just written an email to the TS admins complaining about the bad information available on the TS wiki and status.TS. --Saibo (Δ) 13:30, 20 February 2012 (UTC)
Would it be possible to temporarily run the bot on a different computer, for example on the operator's (User:Luxo's) computer? Users might be frustrated if images remain with the wrong orientation for a long time. I've noticed that some other bot-operated services on Wikimedia projects also are down, presumably meaning that they are running on the same server. --Stefan4 (talk) 13:53, 20 February 2012 (UTC)
Yes, running the bot is possible on every linux computer (in rotatebot's case much bandwidth is needed, tough), but setting up is work. But, in principle the toolserver guys should ensure that this thing is running... :-( --Saibo (Δ) 03:01, 21 February 2012 (UTC)
He's back at work. He run on a other toolserverserver now, and starts every 15 minutes (0, 15, 30, 45)--Luxo 16:38, 21 February 2012 (UTC)
Thank you! --Saibo (Δ) 19:15, 22 February 2012 (UTC)
This section was archived on a request by: Saibo (Δ) 19:15, 22 February 2012 (UTC)

Stopped again

The bot hasn't rotated any image since, at least, yesterday evening. See the history of this file, tagged on 23:10, 22 February 2012. --Edelseider (talk) 15:35, 23 February 2012 (UTC)

  • Latest edit: 2012-02-22T15:15:52. I moved over some images from English Wikipedia several hours ago and they still haven't been rotated. --Stefan4 (talk) 16:39, 23 February 2012 (UTC)
one of the database-server ran out of space, I had to change the database server. Thanks for the notification. --Luxo 21:21, 23 February 2012 (UTC)
This section was archived on a request by: Saibo (Δ) 15:00, 6 March 2012 (UTC)

IFD0:Orientation = 11?

File:BMW - Flickr - yuichirock (2).jpg and File:BMW - Flickr - yuichirock.jpg apparently had their orientation tags set to 11 according to Rotatebot's edit summary. Any idea of what that means? I thought that the orientation only could take values between 1 and 8 and you don't need more than 8 different values to obtain all different variants of mirroring and rotation. Do you think that the files need anything more than the "rotate 270 degrees" that I gave them? Looks enough for the car at least... --Stefan4 (talk) 23:17, 6 March 2012 (UTC)

It appends the values in case of duplicate orientation tags for the edit summary. 11 means two times a tag with "1". Never saw 1 and 1 before... The images were processed by Quicktime (according to EXIF, and it is known that quicktime produces duplicate orientation tags)... If you call exiftool -IFD0:Orientation 20120306230042\!BMW_-_Flickr_-_yuichirock.jpg -a (use -b to get the raw value) you see the dupe tags. Cheers --Saibo (Δ) 23:46, 6 March 2012 (UTC)
Ah, I see. I'm aware that Quicktime produces stupid tags, but I wasn't aware that Rotatebot concatenates them. Thanks! --Stefan4 (talk) 23:49, 6 March 2012 (UTC)
This section was archived on a request by: Saibo (Δ) 23:46, 6 March 2012 (UTC)

Broken upload

See File:Banana cake (bánh tet chuối).jpg. The original version is 3.03 MiB but Rotatebot only uploaded 169 KiB, breaking the file. Was this caused by a bug in Rotatebot? --Stefan4 (talk) 22:01, 10 March 2012 (UTC)

Thank you for watching! I do suspect a network or wikimedia/toolserver server failure during upload. Happens that seldom that there is not really a error detection on rotatebot's side. All files uploaded afterwards are okay, if I see correctly. --Saibo (Δ) 23:10, 10 March 2012 (UTC)
Yes, later uploads look correct and Rotatebot got it right the second time. --Stefan4 (talk) 23:25, 10 March 2012 (UTC)
Okay, again, thanks for being watchful! --Saibo (Δ) 23:51, 10 March 2012 (UTC)
This section was archived on a request by: Saibo (Δ) 23:51, 10 March 2012 (UTC)

Is the bot running?

My images were tagged more than 12 hours ago. If the bot runs every 15 minutes 24/7, why aren't my images fixed? Thanks, Mwanner (talk) 12:26, 19 March 2012 (UTC)

There were some major disagreements in our community recently and one of the supporters or Rotatebot seem to have quit Commons. You may contact the bot-operator. If it turns out that it won't get enough maintenance, I will disable RotateLink. -- RE rillke questions? 15:23, 19 March 2012 (UTC)
Seems to be running now (Rillke appears to have restarted it). --Stefan4 (talk) 14:04, 20 March 2012 (UTC)
This section was archived on a request by: Stefan4 (talk) 14:04, 20 March 2012 (UTC)

Image Rotated OK but Thumbnail Not Visible

Cieszyn Piast Tower.jpg

See File:Cieszyn Piast Tower.jpg ‎- does this image need to be removed, reloaded and rotated, or can the thumbnail issue be addressed so that it can be viewed in my gallery?--Scotch Mist (talk) 11:55, 19 March 2012 (UTC)

It looks correct to me and it also looks correct at User:Scotch Mist/Poland and on this page (see right). Is there still a problem? --Stefan4 (talk) 15:37, 19 March 2012 (UTC)
Purged and now shows up for me. If you do not see it:

Please purge your browser’s cache . (You only need to do it once.)

Internet Explorer: press Ctrl+F5, Firefox: hold down Shift while clicking Reload (or press Ctrl+ Shift+R), Opera/Konqueror: press F5, Safari: hold down Shift+alt while clicking Reload, Chrome: hold down Shift while clicking Reload -- RE rillke questions? 15:37, 19 March 2012 (UTC)

Works for me. Problem solved? --Stefan4 (talk) 23:49, 22 March 2012 (UTC)
This section was archived on a request by: Stefan4 (talk) 23:49, 22 March 2012 (UTC)

Images not rotated

See Special:Contributions/Rotatebot: Rotatebot deletes {{rotate}} templates and logs files but doesn't upload rotated files. --Stefan4 (talk) 23:50, 22 March 2012 (UTC)

And see COM:AN#CommonsHelper blocked? for an explanation of the bug. --Stefan4 (talk) 02:11, 23 March 2012 (UTC)
Luxo has switched off the bot. An edit-token is required now. Don't know how the bot logs-in, but if you attach the session cookies, you can get it this way: query.pages[-1].edittoken. login.php has such a cookie-request for the edit-token already. -- RE rillke questions? 08:57, 23 March 2012 (UTC)
He's back at work. Upload switched to API - other tools will follow. Thanks--Luxo 21:11, 24 March 2012 (UTC)
Thank you! -- RE rillke questions? 21:45, 24 March 2012 (UTC)
This section was archived on a request by: Stefan4 (talk) 20:56, 27 March 2012 (UTC)

Images not rotated 2

hello, I would be happy to rotate an image with Rotatebot. is the name of the picture file: Feldberg_22_03_2012_1.jpg. Thank you --Woelle ffm (talk) 09:41, 23 March 2012 (UTC)

Rotatebot is not currently working (see above). I hope that it will be fixed. --Stefan4 (talk) 13:27, 23 March 2012 (UTC)
I have turned the image itself. I've uploaded a rotated image --Woelle ffm (talk) 18:02, 24 March 2012 (UTC)
Unfortunately, you used lossy rotation. I have reverted this and asked Rotatebot to change it into lossless rotation instead. --Stefan4 (talk) 23:37, 1 April 2012 (UTC)
This section was archived on a request by: Stefan4 (talk) 11:30, 2 April 2012 (UTC)

Stopped again?

No rotations for a couple of hours. Would someone be able to restart the bot? --Stefan4 (talk) 19:25, 3 April 2012 (UTC)

was a database change on the toolserver, he's back to work--Luxo 21:10, 3 April 2012 (UTC)
And now Rotatebot seems to have stopped again. --Stefan4 (talk) 09:16, 6 April 2012 (UTC)
looking for...--Luxo 21:01, 6 April 2012 (UTC)
Stopped again? --Stefan4 (talk) 00:45, 10 April 2012 (UTC)
Seems to have restarted again. --Stefan4 (talk) 16:13, 13 April 2012 (UTC)
This section was archived on a request by: Stefan4 (talk) 13:02, 18 April 2012 (UTC)

Stopped again?

The files I tagged for rotation yesterday haven't been rotated yet. --Stefan4 (talk) 13:02, 18 April 2012 (UTC)

Neither have been mine, I'm waiting for 3 days now... -- Clemens 15:40, 21 April 2012 (UTC)
Seems to have started again... --Stefan4 (talk) 12:20, 24 April 2012 (UTC)
This section was archived on a request by: Stefan4 (talk) 12:20, 24 April 2012 (UTC)

Rotation is not visible in smaller image versions

Look at this, please: Centro_Poliesportivo_Nelson_Rodrigues_-_Rua_para_brincar.JPG. And examine full resolution.

Regards Parzi (talk) 01:57, 16 May 2012 (UTC)

I'm not sure what the problem is. The file has EXIF orientation set and is thus rotated in all resolutions I've checked. It looks like the usual problem: someone has probably rotated it using lossy rotation without resetting the EXIF orientation. --Stefan4 (talk) 11:48, 16 May 2012 (UTC)
THX for the information. With which program and how could I reset the EXIF orientation of an image, if I some day will intend to do it? --Parzi (talk) 14:50, 16 May 2012 (UTC)
I'm using en:Exiftool, a command-line program for Linux and other operating systems, whenever I need to change any EXIF orientation. There are also supposed to be graphical programs doing the same thing, although I've never tried any of those. Another option is to just add the {{rotate}} tag to the image as you did here. That way, Rotatebot will reset the EXIF orientation automatically. --Stefan4 (talk) 15:03, 16 May 2012 (UTC)
Ok. THX. --Parzi (talk) 15:24, 16 May 2012 (UTC)
This section was archived on a request by: Stefan4 (talk) 00:21, 17 May 2012 (UTC)

Stopped?

It seems that Rotatebot hasn't rotated anything for a few days. Is there some error which has stopped the bot? --Stefan4 (talk) 11:48, 16 May 2012 (UTC)

back at work--Luxo 20:32, 16 May 2012 (UTC)
This section was archived on a request by: --Saibo (Δ) 22:23, 22 May 2012 (UTC)

Delete This

Hello ... Pls Delete all Old & New version of this file

commons.wikimedia.org/w/index.php?title=File:Harminder_Singh_official.JPG


Thanks  :) — Preceding unsigned comment added by Harminder singh (talk • contribs) 07:06, 26. Mai 2012‎ (UTC)

This section was archived on a request by: RE rillke questions? 07:27, 26 May 2012 (UTC)

Thanks!

Just wanted to leave my thanks for this fine bot. One of the last years' really big improvements. Dysmorodrepanis (talk) 01:59, 24 May 2012 (UTC)

This section was archived on a request by: Saibo (Δ) 00:02, 14 June 2012 (UTC)

Not working after 2012-06-19T20:29:38

↑. I have tried to poke it via User:Rotatebot/config.js but had no success. Something must be really wrong - edited the error indicator. Luxo has to have a look - have sent an email. --Saibo (Δ) 23:41, 20 June 2012 (UTC)

Works again since 2012-06-21T08:34:54 - it was a server problem (the bot's code was not running at all). --Saibo (Δ) 19:19, 21 June 2012 (UTC)
This section was archived on a request by: Saibo (Δ) 19:19, 21 June 2012 (UTC)

A barnstar for you!

Peace Barnstar Hires.png The Barnstar of Diplomacy
Alexandre Calame, Mountain Torrent, Zxc60617 (talk) 02:50, 28 June 2012 (UTC)
This section was archived on a request by: Saibo (Δ) 18:31, 1 July 2012 (UTC)

Not working after 2012-07-01 13:33

Toolserver looks not good: https://toolserver.org/~bryan/stats/replag/ I guess/hope that is (or is related to) the issue and rotatebot will start again when TS is good again. --Saibo (Δ) 18:40, 1 July 2012 (UTC)

I'm seeing updates to User:Rotatebot/Log, so I assume that the bot has restarted again. Is there a general problem with tools:? You mentioned a similar problem just a few days ago. --Stefan4 (talk) 11:46, 2 July 2012 (UTC)
Yes, works again since 2012-07-02T00:51:21. Don't know the reason. The replag graph for s1 (not sure which DB is Commons anyway) still rises - so that is probably unrelated. I have checked some files (the first ones) for errors and had a look over the log. No errors visible --Saibo (Δ) 20:38, 2 July 2012 (UTC)
This section was archived on a request by: Saibo (Δ) 20:38, 2 July 2012 (UTC)

False positive

Rotatebot shouldn't have rotated this image; File:Demi_Lovato_X-Factor_2012.jpg. Riley Huntley (talk) 23:34, 20 September 2012 (UTC)

But someone requested rotation. -- Rillke(q?) 00:10, 21 September 2012 (UTC)
This section was archived on a request by: Stefan4 (talk) 22:23, 10 January 2013 (UTC)

Not working

For the last 24 hours, if not 48 hours. Please mend (again). Cheers,--Edelseider (talk) 20:19, 24 September 2012 (UTC)

"He" seems to have reconsidered "his" decision. -- Rillke(q?) 21:50, 24 September 2012 (UTC)
This section was archived on a request by: Stefan4 (talk) 22:23, 10 January 2013 (UTC)

approximately 4 days, 2:31 hours to be processed.

Wow, that's one long waiting time --Vera (talk) 16:52, 23 October 2012 (UTC)

This section was archived on a request by: Stefan4 (talk) 22:24, 10 January 2013 (UTC)

Not working?

I see no actions past August 30, Bot or TS broken? --Denniss (talk) 00:16, 6 September 2012 (UTC)

I sent a message to Luxo (talk · contribs), who is in charge of the bot, yesterday, but he didn't react. --Edelseider (talk) 08:35, 6 September 2012 (UTC)
File:Wikimania 2011 Fruits during Tea 2.JPG — such files were responsible. -- Rillke(q?) 11:08, 6 September 2012 (UTC)
Reason was a bug in the login procedure of the bot. Usually he can handle corrupt files like this one, and should not happen again. Greetings--Luxo 17:32, 13 September 2012 (UTC)
And what's the problem now? -- Rillke(q?) 22:38, 15 September 2012 (UTC)
This section was archived on a request by: Rillke(q?) 16:36, 28 February 2014 (UTC)