Category talk:ISO 639 icons

From Wikimedia Commons, the free media repository
Jump to: navigation, search

Do we need to make language icon for all the language registered at ISO 639-1? I can help if needed. Borgx 00:15, 29 June 2006 (UTC)

That would be very useful. We are missing "ro", and there is a lot of activity on Wikipedia in Romanian. - en:Jmabel | talk 00:01, 18 November 2006 (UTC)

Different colours[edit]

It would probably be easier to tell these icons apart at a first glance if they were different colours. Why not have a bot cycle through them and alternative red, green, blue, gold, purple, black? Seahen 12:02, 21 December 2006 (UTC)

There are several hundred languages. Well, I could of course easily change that in the script that creates the images. However, we should NOT just overwrite these images here but use different file names. These icons have a high visibility on nearly all Wikimedia projects and some of them will get really angry if we just shove different colours down their throats. --  (talk) 11:40, 23 December 2006 (UTC)
And please do not attribute changed images to me. I have not created them. Thanks. --  (talk) 11:42, 23 December 2006 (UTC)

Icon for Arabic[edit]

Hi,
in the wiki-editor (both Wikipedia's and in Wikinews's) I tried the code: {{ar}} in order to make the icon for arabic language appear in the article but it doesn`t seem to give out the corresponding icon for arabic language in the article. Either it gives somthing like {{{1}}} or it results in "العربية:" which is arabic for "arabic". I'm not sure if this is a bug and if this applies for other language icons as well, anyway I'm especially worried about the non function of the "arabic" icon since I'd like to link to some arabic language articles. Does anybody know a workaround? Best wishes -- Torsten 14:55, 12 April 2007 (UTC)

You have to use {{ar icon}}. This is actually a template, which may or may not exist on other Wikimedia projects. On commons, you can also use {{internationalization icon|ar}}. --  (talk) 18:57, 22 April 2007 (UTC)
Thanks a lot. - Torsten 13:37, 23 April 2007 (UTC)

Problem of shift[edit]

Hi,

I think there is a problem of shift for some of the ISO 639 icons. It appeared some days ago. It had already happened, but purging the cache has been enough to solve the problem. Now it does not change anything. Those images are used on the translation project on the french wikipedia, and so the shift appears frequently. Anyone here knows where it does come from and how to solve it ? Fryderyk (d) 08:12, 24 July 2009 (UTC)