Commons:Graphics village pump/August 2008

From Wikimedia Commons, the free media repository
Jump to: navigation, search

MauveFlower[edit]

I uploaded this image and the thumbnail on the comomons page is so small. What happened. The actual picture is shown but only if you click on the itsy bitsy teeny weeny thumbnail thingie. After several uploads this is the first time this happened!!??? SriMesh | talk 00:13, 1 August 2008 (UTC)

I must be doing something silly, it happened again for YellowPairedFlower.JPG Help SriMesh | talk 00:44, 1 August 2008 (UTC)
First, it would be nice if you gave specific links, such as Image:YellowPairedFlower.JPG. Second, I don't see a tiny thumbnail on its image description page -- I see the 800x600 preview image http://upload.wikimedia.org/wikipedia/commons/thumb/7/77/YellowPairedFlower.JPG/800px-YellowPairedFlower.JPG -- AnonMoos (talk) 08:38, 7 August 2008 (UTC)


Strange rendering of my SVG[edit]

Hi there,

I uploaded an svg that pass the W3C validation test yesterday evening, but Wikipedia really doesn't want to render it right ... It's about that one Blason FR Offranville.svg. Does anyone has an idea why does WP doesn't like it ? (Its purely a plain SVG from Inkskape, I did not tried to edit it by hand ... What's also funny (maybe related) that it's about my first SVG graphics, and a previous one also has problems rendering in WP ... (Blason SE Ostergotland.svg for reference.) BenAllard (talk) 19:09, 30 July 2008 (UTC)

What's the specific rendering problem? AnonMoos (talk) 08:32, 7 August 2008 (UTC)
Clearly rsvg is making a hash of rendering it, but it is a big file to go exploring the source of, I have only had the briefest glance so far. I can't think why heraldry should need to use gradient fills. Globbet (talk) 23:31, 9 August 2008 (UTC)
I find them moderately annoying, but the guidelines of the French Wikipedia heraldic images project actually require such pseudo-reflective gradients: fr:Projet:Blasons. However, I still don't see what is wrong with the rendering of this particular SVG file... AnonMoos (talk) 23:33, 10 August 2008 (UTC)
Well, I find that the svg source looks entirely plausible (and the same) in Ff & IE, while the rendered image doesn't. On my system, Opera displays the source as nothing but the outline, filled black. Globbet (talk) 20:43, 13 August 2008 (UTC)

Interactive animation[edit]

Friends of SVG may be vaguely interested in the discussion I have tried to start here. Globbet (talk) 07:33, 7 August 2008 (UTC)

rsvg problem?[edit]

I've uploaded image:netanya.svg about a week ago, and since than the system won't create a "png preview" of it - so I can't see it neither on the image page here in commons nor on the Hebrew wikipedia - where I want to add it. At first I thought it was because it is an inkscape SVG, so I've created a plain svg version and upload again - but the image still won't show. The SVG itself doesn't seem to have any problem (when you click on the image name on the image page it looks OK) but when media-wiki tries to convert it to png for "preview" it seems to fail. The best clue I have for this phenomena is on the find duplicates page which says "Error creating thumbnail: /usr/local/apache/common/php-1.5/bin/ulimit4.sh: line 4: /usr/local/bin/rsvg: No such file or directory". Can anyone help sorting this out? thanks, Costello (talk) 09:33, 15 August 2008 (UTC)

xlink:href="/home/gai/tmp/Screenshot-5.png" Is it supposed to have an embedded image in it? -- carol (talk) 09:53, 15 August 2008 (UTC)
I was pretty sure I've deleted it before uploading. That really was it - thanks! Costello (talk) 10:11, 15 August 2008 (UTC)
Are you running a webserver? I was actually wondering if you had the image online if the png would have rendered.... -- carol (talk) 10:23, 15 August 2008 (UTC)

Image credit in image[edit]

Should Image:California-gull.jpg be included in Category:Images with captions (i.e. is such a 'signature' a "caption"?). Can it be easily removed? (I don't know how to do that myself, though I imagine it can be done quite easily.) Richard001 (talk) 06:38, 17 August 2008 (UTC)

That's a case of {{watermark}} rather. It should be possible to clone it out, but the author field in the information template should be updated with the removed information. (This is not strictly a requirement according to US copyright law, since the work is in the public domain, but it's the courteous thing to do, and en:User:Jengod doesn't really seem to have anything to do with the authorship of this image.) LX (talk, contribs) 13:17, 17 August 2008 (UTC)
Oh, right. I have credited the photographer and added it to the watermark backlog. Richard001 (talk) 03:03, 18 August 2008 (UTC)
I've removed the watermark; the new image is Image:California-gull-nosignature.jpg. It could be better, but the signature's gone. I haven't replaced the original file. Bart133 (talk) 21:43, 21 August 2008 (UTC)

Flag of Eschikofen[edit]

I've created this SVG version from this image of the flag of Eschikofen, Switzerland. The original had a border, which I removed from the SVG version. Can anyone find out whether the border is part of the flag, and thus should not be removed? Bart133 (talk) 21:53, 21 August 2008 (UTC)

Assuming that it's controlled by an original heraldic blazon equivalent to "Or, a cross sable", the border would be optional. (This is actually more a heraldry question than a technical image question...) AnonMoos (talk) 14:35, 22 August 2008 (UTC)

how to maintain aspect ration on svg images[edit]

Yes check.svg Resolved

How do I set and fix the aspect ratio on an SVG image ?

Sorry, but I am new at loading images and I cannot find where/how to fix this.

For example

<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 35 50">
<rect rx="10" width="35" height="50" fill="red"/>
<text font-size="50" font-weight="bold" fill="white" font-family="Nimbus Sans L,sans-serif" x="5" y="43">1</text>
</svg>

is "squared off" at 256x256 pixels.

Using preserveAspectRatio does not seem to fix the problem as follows

<svg xmlns="http://www.w3.org/2000/svg" preserveAspectRatio="xMidyMid meet" viewBox="0 0 35 50">
<rect rx="10" width="35" height="50" fill="red"/>
<text font-size="50" font-weight="bold" fill="white" font-family="Nimbus Sans L,sans-serif" x="5" y="43">1</text>
</svg>

as per 1 white, red rounded rectangle.svg

Can the nominal image size be set somehow ?

Pee Tern (talk) 04:04, 22 August 2008 (UTC)


Whenever an SVG is displayed at 256x256 (and is not intended to be), it means that the SVG renderer is not getting enough concrete numerical data in the <SVG... element. Usually the viewBox= is enough, but in this case for some reason it wasn't, so I added width="175" height="250" (these numbers multiplying the viewBox= numbers by 5...). AnonMoos (talk) 14:40, 22 August 2008 (UTC)
Thanks Pee Tern (talk) 23:26, 24 August 2008 (UTC)


Problem with SVG/Inkscape[edit]

I created an SVG picture on Inkscape. It only contained text (it was a font sample). On Inkscape it worked fine, but when I uploaded it here on Commons, it turned into a completely black rectangle and it had to be removed. Why did this happen and how can I make this not happen again? -Anzee (talk) 18:52, 7 August 2008 (UTC)

Here's a good example of what happens. –AnzeeTM 11:20, 8 August 2008 (UTC)

  • To fix it, select the text in Inkscape and go to Path -> Object to Path in the menu. This changes the text from text into a picture of text, so Wikimedia projects don't need the font you used to render it. Wikimedia servers don't have any fonts installed. Bart133 (talk) 21:27, 21 August 2008 (UTC)
They do have some fonts installed, but they may not be under the trademarked names of familiar fonts, and may not have the same individual character metrics... AnonMoos (talk) 15:43, 10 September 2008 (UTC)